MailPoet Will Require PHP Version 5.6 in 2019

Author’s gravatar Kim | | MailPoet News | 6

At the end of 2018, MailPoet will be upgrading its minimum PHP version. Our users will be required to have at least PHP version 7 5.6 in order to use our plugin.

There will be a grace period for users on version 5.6. We will evaluate the length of this period later in 2018.

This fall 2018 we will stop supporting all PHP versions below 5.6.

Not sure which PHP version your site is using? Find out which version you currently have by installing this plugin or by checking in your admin, in MailPoet > Help > System Info (see screenshot).

Sorry, What Is PHP?

PHP is the main programming language powering WordPress and its themes and plugins.

Your host decides which versions of PHP your website runs. This version can be:

  • 7.2
  • 7.1
  • 7.0
  • 5.6
  • 5.5
  • 5.4
  • 5.3
  • 5.2

WordPress requires, at minimum, 5.2 in order to function. However, version 7.2 is recommended.

Why is MailPoet Requiring Version 7?

Firstly, version 7 and above are significantly faster. This means a faster website and better rankings in Google search results.

Secondly, there’s a security risk in running an old version of PHP, as older versions are not updated. For example, after the end of 2018, version 5.6 will no longer receive any security updates.

Thirdly, it is painful for our team to develop software using old standards. This slows down our release schedule and creates issues that are are difficult to discover during our quality assurance process. We’d rather spend our time improving MailPoet than debugging your website.

Who Is Responsible for Updating the PHP version?

You are.

It’s as easy as flicking a switch in your host’s account management interface.

We have a list of upgrade guides for popular hosts. It’s pretty easy on SiteGround, for example.

The only exception to this rule are GoDaddy Managed WordPress plans which forces its customers to use version 5.6.

Will This Break My Site?

Maybe, but you can quickly undo the change. It’s risk free.

If something goes wrong, you can either:

  • Simply revert to the previous PHP version if your site is having serious issues;
  • If you want to try to figure out the problem, find which plugins might be the cause by disabling all of them, one-by-one. Look for plugins that have not been updated in the last 6 months. Some plugins display a minimum PHP version too;
  • Try a different theme. Make sure your own theme has been updated recently;
  • Hire someone to help you in this process if you prefer to have someone else deal with it. We recommend freelancers on codeable.io. They are fast, efficient and professional;
  • Ask your host for help. A good host will be able to help you.

What Are The Risks of Not Upgrading?

MailPoet might not work as expected. If you enquire our support team, we’ll make sure to check the PHP version.

Plan ahead while you have time. In the meantime, we’re available to answer your questions. Don’t hesitate to contact us!

Illustrations by Elobo.

DISCUSSION

    Author’s gravatar

    Great move MailPoet. Hoping to do same for my plugins.

    Author’s gravatar

    I am still afraid to upgrade my blog to PHP 7.2 version because of the compatibility issues. I want to make sure none of them should exists.

    Author’s gravatar

    Yogesh, remember that you can always switch back to a previous version of PHP if you see anything weird on your site.

    Author’s gravatar

    Oh , Its good , time for update

    Author’s gravatar

    Guys, how about HHVM?

    Author’s gravatar

    We tested MailPoet with HHVM v3.27.1 and it is working.

Comments are closed.